Close
Close
Advanced Search

Optolith Heldenverwaltung

Optolith Heldenverwaltung

ADD TO WISHLIST >
Multiple File Formats
Suggested Price €0,00

Dies ist ein Charaktergenerator für die fünfte Version von Das Schwarze Auge.

Das Programm ist für Windows 7+ sowie Linux (Ubuntu 12.04+, Fedora 21, Debian 8; x64) und macOS 10.10+ (x64) verfügbar. Die gegebenen Dateien können sich in ihrer Versionnummer (und damit in angewendeten Änderungen) unterscheiden.

Es kann passieren, dass nicht alle Plattformen zur gleichen Zeit ein Update erhalten (werft einfach einen Blick auf die Änderungsnotizen; ich schreibe bei Updates immer die Versionsnummer und die Plattformen, für die diese gelten, dazu; falls keine Plattform genannt ist, gilt das Update für alle Plattformen).

Dieses Fanprojekt darf aus lizenztechnischen Gründen nur hier publiziert werden. Da es in meiner Freizeit entsteht, kann es sein, dass die Arbeit daran nicht konstant vorangeht. Bitte entschuldigt das.

Changelog

Fehler oder Anregungen/Kritik bitte entweder im Orkenspalter, im DSAforum oder auf GitHub loswerden, wo wir darüber am besten diskutieren können! :)

Alternativ könnt ihr auch eine E-Mail an support@optolith.app schicken.

Falls ihr euch nicht sicher seid, wie ihr die Fehlerberichterstattung etc. am besten angeht, schaut in dem kleinen Guide auf GitHub vorbei. Danke! :)

Kleine Randbemerkung: Da hier offenbar aktuell die Links nicht funktionieren, hier eine Liste:

 
 Customers Who Bought this Title also Purchased
Reviews (22)
Discussions (137)
Customer avatar
Christopher W April 09, 2020 6:25 am UTC
PURCHASER
Hallo Lukas!
Zuallererst Mal vielen Dank für die tolle Software!

Beim Update auf 1.3.1 hab ich aber leider den bekannten Fehler der invalid config Script oder so... Ich hab natürlich deine Ausführung dazu gelesen, aber unter appdata Roaming finde ich keinen optolith Ordner, obwohl ich verborgene Inhalte anzeigen lasse
Customer avatar
David M April 05, 2020 5:19 pm UTC
PURCHASER
Die Software ist nett, der Autoupdater scheint aber etwas zu hängen.
Der Download über das Portal hier dagegen ist miserabel. Als gäbe es keine einfachere Art software bereit zu stellen.
Customer avatar
Lukas O April 05, 2020 11:54 pm UTC
CREATOR
Was genau meinst du mit "der Autoupdater scheint aber etwas zu hängen"? Der Auto-Updater ist leider nicht von mir, aber wenn es Probleme gibt, kann ich trotzdem gerne schauen, ob ich sie lösen kann! :)

> Der Download über das Portal hier dagegen ist miserabel. Als gäbe es keine einfachere Art software bereit zu stellen.
Ich dürfte die Software nicht veröffentlichen, wenn ich sie auf einem anderen öffentlich sichtbaren Weg zur Verfügung stelle, was in den Richtlinien für die Nutzung des Scriptoriums geschrieben steht, da ich Inhalte, für die diese Richtlinien gelten, nutze, daher: Ja, es geht theoretisch einfacher, praktisch ist es aber nicht möglich.
Customer avatar
Moritz P March 29, 2020 5:12 pm UTC
PURCHASER
Moin, es fehlen ein paar Quellenbänder und Regelwerke ist das Richtig? Aventurische Magie III, Götterwirken II, Pandämonium I und II, Hebarium I, Tiergefährten ist das richtig?
Customer avatar
Lukas O March 29, 2020 5:53 pm UTC
CREATOR
Ja, die fehlen noch, das ist richtig. Die Regelbände, insbesondere AMA3, sind leider nicht einfach zu implementieren, daher dauert das immer ein bisschen, bis ich da etwas fertig habe. :/
Customer avatar
Moritz P March 29, 2020 6:11 pm UTC
PURCHASER
Okay, macht ja nichts danke erstmal für die Mühe! ;D Einfach super das Tool! Weißt du zufällig ob es irgendwo die Regelwerk Archetypen als Json gibt? damit ich die Fix da importieren kann?
Customer avatar
Lukas O March 29, 2020 7:02 pm UTC
CREATOR
Kein Problem! ;) Und danke!!! :3
Hmm, also ich selber habe sie leider nicht, aber wenn du magst, kannst du z.B. auf dem oben verlinkten Discord-Server suchen oder fragen, ob jemand da welche hat; ich meine, es gab da mal ne Unterhaltung drüber, dass jemand da ein paar von gebastelt hat. Aber „offizielle“ JSONs hab ich nicht.
Customer avatar
Markus Z March 28, 2020 3:01 pm UTC
PURCHASER
Servus,
ich hab ein Problem bei der Installation von Optolith auf einem frischen Windows 10. Beim Ausführen der executive als Nutzer, wie auch als Admin, startet die Installation. Sie bleibt jedoch bei ziemlich genau einem drittel des Installationsvorgangs stehen. Irgendwelche Vorschläge was da schief gehen könnte?
Customer avatar
Lukas O March 28, 2020 9:15 pm UTC
CREATOR
Hi! :)

Hmm, nicht wirklich... :/ Der Installer ist nicht von mir, da ich mich in dem Bereich leider nicht auskenne, daher habe ich nicht wirklich Einfluss auf den Installationsprozess und kann dir auch nicht genau sagen, wo er da stehen bleiben könnte. Blockiert evtl. dein Virenschutz den Installer? Das ist das einzige, was mir aktuell noch als Grund einfallen würde. Alle anderen Ideen fallen weg, da du das System ja frisch aufgesetzt hast...

Tut mir leid, dass ich da nicht wirklich mehr zu sagen oder behilflich sein kann, auch wenn ich es gerne machen bzw. sein würde. :/
Customer avatar
Markus Z March 28, 2020 10:21 pm UTC
PURCHASER
Alles klar, trotzdem danke ^^ ich geh mal gucken was ich noch so probieren kann.
Customer avatar
Anne D March 27, 2020 12:15 pm UTC
PURCHASER
Hallo Lukas,
herzlichen Dank für das tolle Programm. Eine Frage: Ich finde keine Möglichkeit, AP zuzufügen - könntest du mir da helfen?
Liebe Grüße
Anne
Customer avatar
Lukas O March 27, 2020 3:33 pm UTC
CREATOR
Moin Anne!

Freut mich, dass es dir gefällt!!! :3

Du musst zuerst die Heldenerschaffung im Profil-Tab schließen (Max. 10 AP übrig). Dann kannst du im gleichen Tab unter dem Portrait den Button „AP hinzufügen“ drücken und darüber dann AP hinzufügen.

Hoffe das hilft!

LG Lukas
Customer avatar
Anne D March 27, 2020 3:41 pm UTC
PURCHASER
Wunnebar, jetzt hab ich's! Danke dir!
Customer avatar
Geerd V March 26, 2020 3:37 pm UTC
PURCHASER
Durch das neue Update kommt folgende Fehlermeldung die ich nicht einordnen kann:
Config Invalidity Error
The file is not a valid Optholith config document. Details: validate Json validation error at definitions /config/additonalProperties:should NOT have additional properties.
Customer avatar
Lukas O March 26, 2020 11:41 pm UTC
CREATOR
Der Vollständigkeit halber: Ich hab dir mal auf Facebook geantwortet; falls dir die Kommentarfunktion hier mehr zusagt, kannst du meine Frage aber natürlich auch hier beantworten! ;)
Customer avatar
Martin K March 28, 2020 12:39 pm UTC
PURCHASER
Ich habe das gleiche Problem. Wie ist die Lösung?
Customer avatar
Lukas O March 28, 2020 12:53 pm UTC
CREATOR
Ich nehme mal an, du arbeitest mit Windows (ansonsten ist der Pfad zum Ordner anders).

Du musst Optolith geschlossen haben und dann unter „ C:/Users/<Benutzer>/AppData/Roaming/Optolith“ die „config.json“ löschen. Danach dürfte es wieder normal funktionieren.
Customer avatar
Fabian W March 09, 2020 5:19 pm UTC
PURCHASER
Hi
anscheinend sind zwar die Professionen der Regelerweiterungen enthalten, jedoch sind diese mit den Kulturen des GRW nicht wählbar. Insbesondere ist die Profession der Tsageweihten nicht mit der Kultur des Horasreich kompatibel, was zwar nicht ausdrücklich in Aventurisches Götterwirken zugelassen wird, jedoch zumindest plausibel ist.
Customer avatar
Lukas O March 09, 2020 11:16 pm UTC
CREATOR
> was zwar nicht ausdrücklich in Aventurisches Götterwirken zugelassen wird, jedoch zumindest plausibel ist.

Das stimmt zwar, letztendlich ist das aber eine eigene Interpretation des Fluffs. Und ich habe mir eigentlich für Optolith vorgenommen, eben nur das zu nehmen, was exakt so in den Regeln steht, nicht mehr nicht weniger. Denn nicht jede Interpretation ist gleich und der eine möchte dann aber viel lieber die eine Profession hinzugefügt sehen, findet die andere aber unpassend. Das führt dann ganz schnell zu Diskussionen. Daher muss ich leider bei den offiziellen Regeln bleiben. In diesem Fall macht aber natürlich auch kein Errata Sinn, da die Kulturen ja zum großen Teil aus dem Grundregelwerk stammen, sonst hätte ich dir vorgeschlagen, es Ulisses vorzuschlagen – denn Errata arbeite ich natürlich ein.

Du kannst aber trotzdem alle Professionen auwählen, nämlich indem du links in der Filterleiste nicht "Übliche Professionen", sondern "Alle Professionen...See more
Customer avatar
Till H March 06, 2020 7:40 pm UTC
PURCHASER
Hallöchen :D
Ich habe dummer weise, aus versehen, SEHR weit raus gezoomt... Aber anscheinend kann man nicht einfach so wieder reinzoomen (strg Mausrad, strg + etc). Kann mir evtl. jemand helfen?
Customer avatar
Lukas O March 06, 2020 9:40 pm UTC
CREATOR
Moin! xD

Probier mal Strg+0, Strg+Shift+0 oder Strg+Alt+0. Klappt das? Neustarten von Optolith oder des Rechners behebt das Problem ansonsten bestimmt.
Customer avatar
Till H March 06, 2020 10:11 pm UTC
PURCHASER
Hat funktionert :D
Vielen vielen Dank für die schnelle Antwort <3
Customer avatar
Lukas O March 06, 2020 10:20 pm UTC
CREATOR
Kein Problem! <3
Customer avatar
hans G March 04, 2020 8:38 pm UTC
PURCHASER
Hallo Lukas,

vielen Dank fuer Deine Arbeit und das Update.
Ich hatte 1.2 installiert, welche gestern auf 1.3.1 aktualisiert wurde. Nun habe ich jedoch einen kleinen Bug: nachdem man Spezies, Kultur und Profession bei der Heldenerstellung gewählt hat, muss man alle 8 AP fuer Sprachen und Schriften ausgeben, bevor man den Charakter fertigstellen kann, da sonst der Button ausgegraut bleibt. In 1.2. musste man nicht alle 8 AP ausgeben.

/Hans
Customer avatar
Lukas O March 04, 2020 11:37 pm UTC
CREATOR
Moin Hans,

ich hab dir ja schon im DSAForum geantwortet, aber hier vielleicht noch eine kleine Ergänzung: Der Bug war dann wohl in der 1.2, denn, wie gesagt, muss man eigentlich immer alle AP ausgeben. Insofern gut, dass ich den wohl im Vorbeilaufen erwischt habe! XD

LG
Customer avatar
hans G March 04, 2020 11:42 pm UTC
PURCHASER
Servus Lukas,

danke fuer die Klarstellung! Dann kann ich mich beruhigt auf die Kampagne vorbereiten.

/Hans
Customer avatar
Tobias G March 04, 2020 3:35 pm UTC
PURCHASER
Jep, bei mir ähnlich:

The file is not a valid Optolith config document.

Details:

validate: JSON validation error at #/definitions/Config/additionalProperties: should NOT have additional properties

validate: JSON validation error at #/definitions/Config/properties/herolistSortOrder/enum: should be equal to one of the allowed values
Customer avatar
Lukas O March 04, 2020 3:52 pm UTC
CREATOR
Ich gehe jetzt mal von Windows aus: Du musst Optolith geschlossen haben und dann unter "C:/Users/<Benutzer>/AppData/Roaming/Optolith" die "config.json" löschen, danach sollte es wieder starten können. Würde es dir etwas ausmachen, mir vielleicht die config.json zu schicken (support@optolith.app)? Dann kann ich mir ansehen, welche Sachen denn genau nicht passen und das Problem beheben. Danke schon mal! :)
Customer avatar
Tobias G March 05, 2020 7:30 am UTC
PURCHASER
Dieser Ordner existiert bei mir gar nicht^^
Zumindest nicht an der angegebenen Stelle...?
Customer avatar
Lukas O March 05, 2020 9:23 am UTC
CREATOR
Der AppData-Ordner ist standardmäßig ausgeblendet, du musst also in den Explorer-Einstellungen „versteckte Ordner anzeigen“ aktivieren.
Customer avatar
Tom K March 21, 2020 4:07 pm UTC
PURCHASER
Anscheinend sind zu viele Json Keys vorhanden löschen und Neuinstallation hat bei mir nicht geholfen: Wenn ihr folgendes in die config.json schreibt startet es wieder:
{"herolistSortOrder":"name",
"herolistVisibilityFilter":"all",
"racesSortOrder":"name",
"culturesSortOrder":"name",
"culturesVisibilityFilter":"common",
"professionsSortOrder":"cost",
"professionsVisibilityFilter":"all",
"professionsGroupVisibilityFilter":2,
"advantagesDisadvantagesCultureRatingVisibility":true,
"talentsSortOrder":"group",
"talentsCultureRatingVisibility":false,
"combatTechniquesSortOrder":"name",
"specialAbilitiesSortOrder":"groupname",
"spellsSortOrder":"property",
"spellsUnfamiliarVisibility":false,...See more
Customer avatar
Cor C March 29, 2020 12:29 pm UTC
PURCHASER
Ist zwar schon etwas her aber ich schicke die Datei einfach mal, hatte genau das problem

Das Löschen der Datei hatte zum erhofften erfolg geführt.
Vielen Dank
Customer avatar
Stefan W March 03, 2020 7:26 pm UTC
PURCHASER
Hi,
hab beim Starten immer folgende Fehlermeldung:

The file is not a valid Optolith config document.
Details:
validate: JSON validation error at #/definitions/Config/additionalProperties: should NOT have additional properties

auch schon neu installiert.
Customer avatar
Lukas O March 03, 2020 7:35 pm UTC
CREATOR
Moin!

Hast du es auch mit der 1.3.1 versucht?
Customer avatar
Stefan W March 03, 2020 7:37 pm UTC
PURCHASER
jetzt gehts.
Habs nochmal deinstalliert und zusätzlich den ordner in Appdata gelöscht :)
Customer avatar
Lukas O March 04, 2020 12:45 pm UTC
CREATOR
Ah, okay. Sorry, hab deine Nachricht gestern nicht mehr mitbekommen! *versteckt sich hinter dem Bildschirm* Aber da es ja jetzt geht, ist ja alles gut! XD
Customer avatar
Tobias D February 29, 2020 10:55 am UTC
PURCHASER
Hallo Lukas, ich habe einen Fehler bei den Avesgeweihten gefunden. Wenn man die Sonderfertigkeit Zugvogel hat, kann man auch Liturgien der Rahjakirche und der Phexkirche nutzen. In der Beschreibung ist es auch korrekt beschrieben, allerdings befinden sich in der Liturgieauswahl dann anstatt der Rahjaliturgien, Travialiturigien. Ich fänd cool wenn das geändert werden könnten.

LG
Customer avatar
Lukas O February 29, 2020 11:55 am UTC
CREATOR
Moin Tobias!

Klar kann das geändert werden, dafür sind Bugs ja da! ;) Vielen Dank für die Meldung! :)

LG Lukas
Customer avatar
Niklas B February 24, 2020 10:05 am UTC
PURCHASER
Hey Lukas, Programmieren kann ich leider nicht aber ich habe jetzt Zeit in den Semesterferien und wenn ich dir helfen kann, indem ich irgendeine Stumpfe Arbeit übernehmen kann (irgendwelche Regeln Sortieren und korrekt irgendwohin copy-pasten), gib Bescheid und ich bin dein Mann - ich finde das Programm der Hammer und je früher Aventurische Magie 3 drin ist, desto leichter ist mein DSA-Leben :D

LG
Customer avatar
Lukas O February 24, 2020 10:32 am UTC
CREATOR
Moin Niklas!

Tatsächlich ist die „stumpfe Arbeit“ für AMA3 bereits getan, es fehlt da nur die komplexere Logik in einigen Bereichen – wie es tatsächlich auch bei den meisten fehlenden Büchern der Fall ist. Solltest du Inhalte dringend brauchen und nimmst in Kauf, dass das Programm instabiler ist, sowie dass AMA3 nicht vollständig ist (Pakte und Geoden funktionieren bspw. noch nicht ordnungsgemäß), kannst du dich gerne mal auf dem oben verlinkten Discord-Server melden, dann kann ich dir Vorabversionen zur Verfügung stellen. Da wäre es dann natürlich auch klasse, dass, wenn ich da was spezielles zum Testen habe, du – natürlich nur, wenn du magst – da auch hilfst – das kommt der gewünschten „stumpfen“ Arbeit vielleicht etwas näher! ;P

LG Lukas
Customer avatar
Jörg S February 22, 2020 5:19 am UTC
PURCHASER
Geht´s nur mir so oder könnt Ihr auch keine Abenteuerpunkte hinzufügen? Hab das Programm schon 2x Reinstalliert, einen neuen Char generiert, aber nie konnte ich AP hinzufügen. Das Kästchen und die Schrift darin sind ROT!!! XXX um Hilfe
Customer avatar
Lukas O February 22, 2020 9:59 am UTC
CREATOR
Das ist ein bekannter Bug, zum Glück recht einfach zu umgehen: Wenn du eine AP-Zahl einträgst, einfach einmal aus dem Feld klicken, also dass der Cursor nicht mehr drin ist. Dann wird das Feld normal und du kannst den Button zum Hinzufügen verwenden. Beim nächsten Update wird das wieder normal funktionieren
Customer avatar
Miriam L February 07, 2020 4:20 pm UTC
PURCHASER
Hey Lukas,
Ich kann's dir grad nicht genau beschreiben, da ich es nur einmal bisher verwendet habe - jetzt habe ich wieder Gelegenheit und werde dir dann gerne ausführlich rückmelden, was mich beim letzten Mal gestört hat :). Gerne auch aus Programmierersicht (oder falls du jemanden zum Code Review brauchst)
Customer avatar
Lukas O February 07, 2020 4:33 pm UTC
CREATOR
Moin! :)

Danke!! :) Ich nehme alles an Feedback auf, was ich bekommen kann ;); wenn du etwas aus Programmierersicht beisteuern möhtest, bin ich dafür ebenso offen!

Zum Code Review: Das wäre natürlich auch nicht schlecht. Hat bisher jedenfalls noch niemand gemacht (ich klammere eigene Analysen und Refactorings mal bewusst aus), daher bin ich dafür auch offen!

Klang vielleicht etwas schwammig jetzt, aber wie oben gesagt, nehme ich gerne jedwedes Feedback an, besonders gern aber natürlich aus für bisheriges Feedback "unüblichen" Perspektiven, also deinen letzten beiden genannten Punkten.

Vielen Dank auf jeden Fall bereits im Voraus für dein Feedback!!
Lukas
Customer avatar
Miriam L February 08, 2020 1:21 pm UTC
PURCHASER
Ich verstehe das richtig, du studierst noch? Macht ihr sowas wie code reviews, pair programming etc. im Studium? Denn so ein Projekt wäre ja schon auch ne coole Sache, mit Kommilitonen dran zu arbeiten und dann eben solche Techniken anzuwenden - ich wünschte, bei mir wäre das vorgekommen, ich hab das nämlich erst Jahre später kennen gelernt (aber wir haben auch nix über Versionierung, arbeiten mit Github oä gelernt). Wenn ich Zeit finde, schaue ich mir alles gerne an und melde mich (auf den passenden Plattformen ;)). Allerdings bin ich berufstätig und hab zwei Kinder, da ist wenig Zeit :)

VG

Miriam
Customer avatar
Lukas O February 08, 2020 3:50 pm UTC
CREATOR
Genau, ich studiere noch. Aber nein, sowas machen wir (leider) nicht. Unser Medieninformatik ist nicht so stark auf Informatik ausgerichtet. Man bekommt ein Grundverständnis in mehreren Bereichen, aber für Code Reviews etc. ist nicht wirklich Zeit. Es wäre auch eine coole Sache, mit anderen daran zu arbeiten, das Problem ist da aber leider, dass man im Studium nicht ausreichend Kenntnisse bekommt. Man bekommt eine Einführung in JS, das wars aber auch. Für Optolith müsste man sich erst genauer mit JS, TS, FP und React auseinandersetzen, und das wäre ein immenser Aufwand. Ich habe auch mal Leute gefragt, aber genau aus diesem Grund haben sie es nicht gemacht, und das kann ich gut verstehen. Zumindest haben wir ein wenig Git im Studium, aber das auch nur, weil der Dozent drauf Wert legt, es mal genutzt zu haben, im normalen Plan ist es nicht. Mein Studium hat mir für Optolith auf der Informatikseite daher so gut wie nichts gebracht; alles self-learned.

Ja, alles gut, RL geht IMMER vor und ich...See more
Customer avatar
Jörg S February 06, 2020 8:17 pm UTC
PURCHASER
Hi Lukas. Nachdem ich eine gute Erziehung genossen habe, weis ich natürlich das wenn man was geschenkt bekommt, nicht jammer soll aber ich fände es Megahammergeil wenn du, wenn du mit Aventurische Magie II durch bist das gleich mal online stellst weil wir warten darauf wie auf ein Stück Brot^^
Customer avatar
Lukas O February 06, 2020 8:19 pm UTC
CREATOR
Das ist tatsächlich auch kurzfristig zum neuen Plan geworden xD, da in diesem oder im nächsten Monat die französische DSA-Version fertig ist und Optolith diese auch unterstützen wird. Zum Release oder kurz danach werde dahingehend auch Optolith ein Update spendieren. Wenn AMA2 bis dahin fertig ist – wovon ich ausgehe –, kommt es mit rein. ;)
See 16 more
Narrow Results
 Follow Your Favorites!
NotificationsSign in to get custom notifications of new products!











 Recent History
Product Information
Platinum seller
Community Content
Author(s)
Artist(s)
Format
Original electronic
Scanned image
These products were created by scanning an original printed edition. Most older books are in scanned image format because original digital layout files never existed or were no longer available from the publisher.

For PDF download editions, each page has been run through Optical Character Recognition (OCR) software to attempt to decipher the printed text. The result of this OCR process is placed invisibly behind the picture of each scanned page, to allow for text searching. However, any text in a given book set on a graphical background or in handwritten fonts would most likely not be picked up by the OCR software, and is therefore not searchable. Also, a few larger books may be resampled to fit into the system, and may not have this searchable text background.

For printed books, we have performed high-resolution scans of an original hardcopy of the book. We essentially digitally re-master the book. Unfortunately, the resulting quality of these books is not as high. It's the problem of making a copy of a copy. The text is fine for reading, but illustration work starts to run dark, pixellating and/or losing shades of grey. Moiré patterns may develop in photos. We mark clearly which print titles come from scanned image books so that you can make an informed purchase decision about the quality of what you will receive.
Original electronic format
These ebooks were created from the original electronic layout files, and therefore are fully text searchable. Also, their file size tends to be smaller than scanned image books. Most newer books are in the original electronic format. Both download and print editions of such books should be high quality.
File Last Updated:
March 03, 2020
This title was added to our catalog on April 15, 2017.